Skip to content

Clinical Updates

MedicalDirector Clinical & Pracsoft 4.0b patch

The following patch can only be applied to MedicalDirector Clinical & Pracsoft version 4.0. This patch must be applied to all Workstations and the Database Server.

28 April, 2021

Issues Addressed

Clinical

  • Several performance and stability improvements.

Pracsoft

  • Updated AIR to allow COVID-19 provider numbers for immunisation uploads.

Important Upgrade Information

Please find documentation below to assist with your planned upgrade

Please note that the following operating systems are not compatible with the Installer for MedicalDirector Clinical 4.0:

  • Server 2003
  • Small Business Server 2011
  • Windows XP
  • Windows Vista
  • Windows 7

Windows 7.1 versions and above are compatible. Your IT partner may be able to assist you with the necessary operating system updates to enable this upgrade and any associated cost.

All MedicalDirector Clinical practices will need to upgrade to at least version 4.0+ to be compliant with Active Ingredient Prescribing.

If there is anything more we can help you with, simply contact a Customer Service agent via Live Chat during support hours, or call 1300 300 161.

You may also like to refer to the Online Product Help section of our website. Product Help is a comprehensive help file of all MedicalDirector products.